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Access Basics Part 1
Overview, Tables and Data Manipulation
General Database Concepts & Terms

What is a database? 
A database is an organized collection of data related to a topic or purpose. The purpose of a database application is to provide the means to store and retrieve data in an organized and efficient manner. 
Access is a relational database
[image: image12.png]A relational database consists of multiple tables linked together by at least one common field. Each table is a storage container and contains facts about a single topic only. For example, one table would not contain information about both students and faculty. When you use your data, you can combine fields from more than one table (if a relationship exists between the tables) through the use of queries. 
After the tables are created, relationships are defined to link the related data together by the field(s) they have in common. 
Database Terms
A flat-file database contains all the information about a topic in a single table or file. It does not physically interconnect with or point to other tables. An example of a flat-file type would be a spreadsheet file or word processing table. 
A relational database consists of a collection of one or more tables that “relate” to each other through at least one field they have in common.
A table is a unit of data storage. Tables should contain database records about one topic only. What tables might you find in a database for: 1) course registration? 2) staffing? 3) a bookstore? 
Relationships are created to link separate tables that contain related data together. A relationship works by matching data in key fields – usually a field with the same name in both tables. 
A database record contains all the information about a single item, e.g. a product in a table of Products. A record is represented by a horizontal row in a table and is divided into fields. 
A field is the smallest division of a record and is represented by a column in the table, e.g. last name or phone number in an Employees table.
Compatibility of Access Versions

This course will be taught using Microsoft Access 2003, but most of the tools and techniques are the same or similar for users of earlier versions (Access 97 or 2000).
Access will only allow you to modify a database that was created or converted to the current version. If you have a database created in an earlier version, you may either
· open the database in view mode only (no modifications allowed), or

· convert the database to the version you are currently using
If you choose to convert, a new database file is created, leaving the previous database file intact. 
To convert the database to an earlier or later version of Access, select Tools, Database Utilities, Convert Database, and select the version.
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The Database Window 

An Access database is a collection of objects, not just a single table of data. One database file contains the tables as well as queries, forms, reports, and other objects that help you use the information in the database. 

Creating a new database or opening one that already exists is done through the File Menu. Click on File, then New Database or Open Database, depending on whether you are creating a new one or opening an existing database. Once you have given the name of the database, the Database window will appear.
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The Database window is the command center from where you can create and view objects in your database. 
· To edit or view an existing object, simply click the appropriate category on the left, select the object and click Open or Design. 
· To create a new object, click New.

· To delete an object, select it and click the Delete button (black X).

· The remaining four buttons in the Database window toolbar allow you to view the objects as large icons, small icons, a simple list, or a detailed list where you can view and sort objects by name, description, created and modified date.

· To view or change the properties of an object, right-click it and click Properties. 

As you create objects and open new windows in Access, the menu bar and toolbar change accordingly to display commands and options that are applicable for working in each window.
You can minimize, maximize, restore or close the Database or Access windows by clicking the buttons in the upper right corner of the window.
Access Database Objects

An Access database may consist of the following objects. These can be cut, copied, pasted, or imported from or exported to another database.
Tables contain all the data stored in a database. Each table is organized into fields (columns) and records (rows) and should contain data about one subject only. For example, a single table should not contain information about students and classes. Relationships are used to show how the data from one table is related to data in another table. A table may be contained in the same database file or you may attach to tables residing in other databases or applications. One must define table structure of the database tables before creating any of the other database objects.
Queries enable you to join related tables and select the fields from the various tables you wish to view. By creating your own criteria statements, you can specify the records that you wish to view. The results of a query look much like a table, with data in rows and columns.
Select Queries select records from a table and present them in a datasheet format. A query's results may be viewed in a form or report or used as the basis for additional queries. A special category of queries called Action Queries provides a means for affecting many records at once. Types of action queries are Make Table, Append Records, Update Records, and Delete. 
Forms are used to view, edit, or enter data into a table. Data may also be entered into a table directly via the table's datasheet. Columnar and customized forms can display a single record at a time. Forms can be customized with command buttons, drop down lists, radio buttons, etc. for more convenient data entry and editing. Forms are best viewed on-screen but may be printed.
Reports are the means for printing data from any table or query according to your own design. Tools are available that allow you to sort, group, summarize and subtotal fields. Reports appear in print preview and are best viewed when printed.
Macros automatically carry out a task or a series of tasks for you. For example, you could attach a macro to a command button that when clicked would automatically run a report. 
Modules are a set of procedures and statements stored together to do some actions to your database that you would write in Visual Basic.
Pages: A data access page is a special type of Web page designed for viewing and working with data stored in an Access or SQL Server database from an intranet or the Internet. 
Working with Tables
Table Design vs. Table Datasheet View

To view the data within a table, open the table in Datasheet view. Click on the table name and then choose Open from the database window toolbar or double-click on the table name. 
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This displays data from the table in Datasheet view arranged in columns and rows, similar to a spreadsheet. Datasheet views may be customized for printing or viewing by sorting, sizing, changing fonts, moving, hiding, or freezing columns. 
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From Design view you can create a table, add fields, change properties, rename fields, etc. Toggle between Design and Datasheet view by clicking on the first button on the toolbar. 
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Navigating a Datasheet 

The record navigation buttons are located in the lower left corner of a datasheet or a form. You may also go to a specific record number by entering the record number in the record number box.
	PageUp or PageDown
	Move forward or back one page of records at a time

	CTRL+Home
	Positions cursor in the first field of first record

	CTRL+End
	Positions cursor in the last field of last record


	F5
	Moves to the record number box where you can select record to go to


Resizing columns/rows

Resize rows or columns by positioning the mouse pointer on any border and dragging the border to the desired position. To resize a column to fit the data it contains, double-click the right border of the column heading.

Rearranging, Hiding, and Freezing Columns

To rearrange the order of the columns, select the column to move by clicking on the column heading and dragging to the desired location. To Hide or Freeze a column, choose the desired action from the Format menu, or right-click on the column and choose from the menu.
Other items on the Format menu allow you to change the font or eliminate the gridlines (Format, Font and Format, Datasheet). 
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A datasheet is displayed sorted by its primary key. To sort by another field, select the column(s) to sort by and click on either the ascending or descending sort button. The sort buttons can be used to sort by more than one field if they are adjacent to each other and will sort from left to right with the leftmost column being the primary sort. Note: you will only see the secondary sort if there are duplicate values in the primary sorted column. Note: for more flexibility in sorting, use a filter or query. 
Selecting Data in a Datasheet

	Portion of a field
	Click where you want to start selecting and drag across the data

	Entire field
	In a datasheet, click the field's left edge; in a form, click the field's label

	Adjacent fields 
	Click the left edge of a field and drag to extend the selection

	Column
	Click the field selector at the top of the column you want to select

	Row (record)
	Click the record selector (box to the left of the record you want to select)

	Multiple rows
	Click the selector of the first record you want and drag to the last record

	Multiple columns
	Click field selector in first column you want and drag to last column

	Entire Datasheet
	CTRL-A or click selector in upper-left corner of datasheet
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Printing Table Data

You can print records from a datasheet directly without first creating a report. To print the data:

1. Open the datasheet

2. Apply any formatting features such as changing fonts, hiding/sizing columns, etc.

3. Set the margins and orientation (portrait/landscape) by choosing File, Page Setup.
4. Choose File, Print Preview to see how the datasheet would look if printed. Click Close in the Print Preview toolbar or click View, Datasheet View to return to Datasheet view.
5. Choose File, Print to print the datasheet. 
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New data records may be added through Table Datasheet View or a Form by clicking on the asterisk on the navigation bar. All new records are added at the end of the datasheet and will be placed in the correct sorted order when the datasheet is closed. 
To save the record, press Shift-Enter. To cancel creation of the record, press Esc. 
Note: It is not necessary to save a new record as it is automatically saved to the database file when your cursor leaves the record. 
To switch from viewing all records to data entry mode, choose Records, Data Entry. To again display all records, choose Records, Remove Filter/Sort. 
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Click in any field to edit its data. Edits are saved as soon as you move to another record, or when you close the form or datasheet. When editing a record, a pencil symbol is displayed in the record selector on the left side of the current document. When you move to another record, the symbol disappears, indicating that you have left edit mode and changes are saved. To cancel changes to a record, press Esc.
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The Undo command on the Edit menu displays a different message depending on the procedure most recently completed. It may display Undo Typing, Undo Current Field/Record or Undo Saved Record. Note: as soon as you begin editing another record, apply or remove a filter, or switch to another window, your changes are written to the database file.
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To delete a record, select it and press the Del key (or choose Edit, Delete). Note: you will get one opportunity to change your mind. If you are deleting data from a single field, you will be able to use Undo. If you are deleting a record, there is no Undo. The record is permanently deleted from the database file and cannot be recovered except from a backup copy of the database. 
Data Entry Shortcuts

CTRL-; writes the current date to a field; Ctrl-: writes the current time
CTRL-' copies the data from the field immediately above
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You can use the Cut, Copy, and Paste features under the Edit menu to move or replace data. Select the fields or columns you want to copy or cut. Choose Copy (or Cut) from the Edit menu. Select the destination field or fields, or switch to the Windows application you want to paste the data into and then choose Paste from the Edit menu. Shortcuts are Ctrl-X, Ctrl-C and Ctrl-V.
Note: you must select the same number of fields to paste into. For example, if you copy an entire record, you must select the fields for an entire record to paste into.
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When you want to find a specific record or find certain values within fields, use Edit, Find to go directly to a record and jump to all other records that meet your criteria. To find a specific value in a field: 1) click in the field where you want to search; 2) choose Edit, Find; 3) type in the value you wish to find and then choose a button to move to the matching record.
Note: After you close the Find dialog box, you can find the next occurrence of the value you most recently searched for by pressing SHIFT+F4. This method of finding data can be used in either in a form or in the datasheet view of a table.
Filtering Records 
Use Filters to specify the records that you want to appear in a datasheet or form view of a table, or to specify records in a query result set. Access provides three methods of filtering data.
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This method is fastest and simplest; you establish criteria by selecting all or part of the data in a field. Only those records matching the selected sample will be displayed.
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Enter the filter criteria into a blank datasheet form of the table. You can either type in the criteria or select matching fields from a drop down list.

Apply a Filter/Remove Filter [image: image10.png]



Note: to apply a filter, click on the Apply Filter button. This is also the Remove Filter button. When the button is depressed, a filter is in effect; when it appears as raised, no filter is active. 
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Note: You may also right-click with the mouse to display a menu where you can Filter by Selection, Filter Excluding Selection, Filter For (older Access versions, works like Filter by Selection except you type in the item to filter by), and Remove Filter/Sort. 
Advanced Filter/Sort [image: image11.png]



This is the most powerful and versatile filtering method and allows you to sort and filter in one step. While you cannot save a filter directly, you can opt to save it as a query for later use by choosing File, Save as Query. To use the filter grid, choose Records, Filter, Advanced Filter/Sort.












Access1.doc
Computer Training & Support Services, Colorado State University
Page 5 of 6

[image: image20.png]Record: (I4] « [ 1 [ J»1)pH] of &



